Common Playback Problems

From BakaBT Wiki
Jump to: navigation, search

On this page is a compiled list of commonly encountered problems when playing videos on different platforms.


Contents


Platform Agnostic

Windows

Please keep in mind that all solutions for the following problems assume that you have CCCP installed on your computer.


I tried playing a video and the sound is awful! However, nobody else has complained...

Select your speaker configuration from the drop down box on the first page of the CCCP Settings window. Screenshot Run CCCP configuration again, and select an audio setting that best fits your speakers. You'll most likely have a 2.0 set-up.

  • True multi-channel sound can only be obtained with proper physical speaker configuration. Even if you have a 5.1 system, running a normal 3.5mm stereo output from your computer to it will only deliver 2.0 output.


Why is the sound and video not synced in my h264 file?

Stolen from Psyren's H.264 Guide

This guide is intended for use by those who are currently using the latest CCCP (version 2008-1-24 as of this guide). For those who are not using it, find a way to disable your codec pack's h264 decoder.

Some preliminary steps
  1. Using Windows Media Player or VLC makes this guide pointless. I recommend Media Player Classic (included in the CCCP), or the newer Media Player Classic Home Cinema (google 'MPC HC').
  2. Free up your RAM. A lack of free RAM has been known to cause streaming problems between your HDD and CPU when playing video on older PCs, made all the worse by the CPU barely being able to keep up. Download FreeRAM XP Pro and run it to clear some free space in your memory before attempting to play the video.
  3. This is sort of a 'last resort' step, since it removes some of the eye candy that soft subs can provide. Pre-buffer the subtitles. This will cause special effects such as fading or dynamic resizing to not display, but it will remove a fair amount of laggy spots on h264 video. To do so, go to your CCCP start menu folder -> Filters -> VSFilter configuration. Go to the Misc. tab and check 'Pre-buffer subpictures'. Alternatively, if (for what ever reason) you use MPC's subtitle renderer, then go to MPC's options menu, click on the Subtitles option on the left side and make sure 'Number of subpictures to buffer ahead' is not set to 0. I have no idea what a good figure might be, as I've never had to use that option, but the default value is 3.

Now, onto the main part:

Step 1
  • Go to your CCCP start menu folder, and click on the settings icon. Uncheck the 'h264' button, then click Next -> Apply. You MUST do this step first in order for the next to work.
Step 2
  • Find and install CoreAVC Professional. Google (amongst other resources) is your friend here.
  • Verify that playback will use the h264 codec you just installed instead of using ffdshow by playing a h264 video in MPC. If successful, the ffdshow video icon will not show up in your taskbar. Done.

If, after applying these 'fixes', your PC is still unable to play SD h264 encodes, then it's definitely time for a new PC or an upgrade. Remember, it's not the codec at fault, it's your PC. Don't complain to us that the PC you bought when the Beatles were around can't handle it.


I hear dual audio playing in both languages!
  1. Before anything, close the video.
  2. Get into the audio codec's settings. Programs -> Combined Community Codec Pack -> Filters -> FFDShow Audio Decoder Configuration.
  3. Select the "DirectShow Control" menu option on the left.
  4. Make sure the "Multiple ffdshow instances:" is set to one of the options that contain "only one". If it already is, select either "only one - check all previous filters" or "only one - check all filters in graph" if the other two still don't work. If by some weird chance this still doesn't fix your problem, use a different player. However, I have yet to find this solution not to work.
  5. Play the movie again, and only one audio track should be playing now.


When I switch subtitle and/or audio tracks, the playback freezes!
  1. This has happened for me only with ogm/ogg, only once on mkv videos. Unfortunately the only workaround to try is switching players. Please check the Playback Forum for help if changing players doesn't resolve this issue.


Obviously, please check the Playback Forums for issues not mentioned in here.

Second obviously, get the CCCP, this is emphasized enough that everyone should have it if they can use it. (If you haven't already, you must be truly stubborn!)


Windows 7 professional - MPC HC(tested on 1.3.1249.0) does not display subtitles
  • Applies to MKV/OGM.

Solution:

  1. Enable the internal subtitle filter:
 MPC Options -> Playback -> enable "Auto-load subtitles"

Source: codecguide.com Make DirectVobSub a preferred filter: MPC Options -> External Filter -> click "Add Filter..." -> select "DirectVobSub (auto-loading version)" and click OK -> choose "Prefer" 2.

Mac

I tried playing an AVI file in Quicktime Player (or some other QT-based player) but the video doesn't show up. What's wrong?

Two possibilities exist:

  • The AVI file uses DivX or XviD for its video track and you do not have a DivX codec installed. To resolve this, install Perian Quicktime Components.
  • Your AVI file is one of the rare videos that Quicktime/Perian will not play for some reason. The solution to this problem is to play the video with one the standalone video players listed at Mac Video Playback.


I have Perian installed, but MKV video files are either associated with a non-QT player or are not associated with any player at all. How can I fix this?

By default, Quicktime Player cannot open MKV files. To fix this, first install Perian's Type Installer. Because of this, even when Perian is installed, it will not show up as an application that is capable of opening MKV files. If MKV files are still not associated with QT Player after that, use File > Get Info on any MKV file in the Finder, change its association in that window, and click "Change All...".


I experience poor performance, stuttering, tearing, etc playing HD (1080p) h264 video in Mac OS X.

There is also a wealth of information on various blogs and forums regarding high resolution h264 playback in OS X, including: tweak VLC decoder options, general discussion on 1080p playback, forcefully update/replace Perian plugins. It has been reported that some Macs running OS X, even very high end Core 2-based Mac Pros, have issues decoding and displaying complex high resolution h264 streams. If Perian, VLC, or MPlayer (including pre-release or latest VCS builds) will not play HD h264 smoothly, try the OS X versions of XBMC or CorePlayer.

Linux

Common Linux playback problems usually have nothing to do with codecs like with Windows and can get pretty intricate so it is best to seek information and help from the Linux Video Playback page or the forums.